Managing a WordPress site? Make sure you review what version of PHP your site is running on.

As of December 2019, around 62.2% of WordPress sites are running on outdated, prior to 7.2 version of PHP. These sites are vulnerable to hacking.

Read More

The safest PHP version that you should be using is the current revision, 7.4, or version 7.3.

So what exactly is PHP? “Hypertext Preprocessor is a server-side scripting language designed for Web development that is also used as a general-purpose programming language.” Simply put, a lot of sites are built on PHP programming language. All WordPress sites in particular.

The primary reason why you need to update your PHP is that the versions prior to 7.3 are no longer receiving security patches, so your site becomes extremely vulnerable to hacking.

Final Takeaway – Considering the fact that only 37.7% of websites are on PHP version 7.3 or higher, the chances of you having to deal with this issue are greater, at least on one of the sites that you manage.

When you log in to your WordPress dashboard, you will see a warning message which is a clear indication to update your PHP version.

update-php-version

Upon seeing the message, you need to contact your hosting company and ask them about the steps that need to be taken to get your PHP updated to version 7.3 or higher.

Although your hosting company will assist you with everything, you will have to check on all of your plugins before updating.

You can even check the version of your PHP by installing this PHP plugin. Have a look to find out where each version of PHP is in their life cycle according to php.net.

supported-versions

Updating your PHP isn’t complicated. You can start by backing up your website. However, outdated plugins and themes can make it seem complicated.

Theme & Plugin Compatibility with New PHP Versions

At times, you may find that the older plugins and older themes or the custom plugins aren’t compatible with 7.3 or higher versions. Before updating your PHP, it is advised to check which ones are likely to create compatibility issues and update or replace them.

If you have a very outdated theme and want to update it, you will have to make certain adjustments for a more recent version. Themes that have a high risk of upgrading problems are those that use advanced editors such as Visual Composer. We have observed that these editors usually generate layout, menu, etc. problems when upgrading the theme.

To avoid facing any problems, it is necessary that you resolve any issues before upgrading your PHP version. We suggest you follow the process in the following order to make things easier.

  • Delete any plugins that are not in use.
  • Check if there are any compatibility issues with the plugins and themes using PHP Compatibility Checker.
  • Consider using a different plugin in case the latest version of plugins isn’t compatible with 7.3 or higher.
  • Next, go to your web hosting control panel and find the PHP section where you will see the ‘upgrade your website’ option.

Besides, you can always reach out to us if you get stuck at any stage! Our experienced personnel is ready to help you out.

Close